Multicast by Gre tunneling

Multicast,… not so popular ?, why ?. Because of scalability. not all border router installed with multicast enabled. Beside that, a few application is running on it. Now, the question how to resolve the above problem when you’re not sure that your above provider router support multicast or not ?. Simple, using tunneling. Internet community is developing AMT (Automatic Multicast Tunneling), but the software still in progress. So, let’s tunnel with gre.

In here, I’m using tunneling between Linux box and Cisco router.

here reference for gre tunneling on cisco,

http://www.cisco.com/en/US/tech/tk828/technologies_configuration_example09186a00801a5aa2.shtml

and for gre tunnelin in linux box, you read LARTC howto. url ??…googling…

Here my scenario

The

[Network of streamer] —–[Linux box] —-[internet]—–[Cisco] —-[network of client receiver]

192.168.1.0/24 —–[192.168.1.1 – 202.169.224.x] —-[internet] —-[202.158.51.xx] —–[a.b.c.d]

1. First step, make tunnel config, and enable the pim at cisco router.

Here configuration in linux box for tunneling

ip tunnel add cbn mode gre local 202.169.224.xx remote 202.158.51.xx ttl 255
ip link set cbn up multicast on
ip addr add 192.168.10.1/30 dev cbn

And configuration for cisco at other side,

!
ip multicast-routing
Enables IP multicast routing.
!
interface Loopback0
ip address 202.158.51.xx 255.255.255.255! Tunnel source interface

interface Tunnel0
ip address 192.168.10.2 255.255.255.252
ip pim sparse-dense-mode
tunnel source Loopback0
tunnel destination 202.169.224.xx
!

interface Ethernet0/0
ip address 10.2.2.2 255.255.255.0
ip pim sparse-dense-mode
!

ip pim bidir-enable
ip mroute 192.168.1.0 255.255.255.0 Tunnel0

This Mroute ensures a successful RPF check for packets flowing from the source.
!— 192.168.1.0/24 over Shared tree in case of Dense more and SPT in case of Sparse mode.
!
ip mroute 202.169.224.xx 255.255.255.255 tunnel 0
This Mroute is required for RPF check when Sparse mode multicast traffic is
!— flowing from RP (assuming 202.169.224.xx as RP) towards receiver via tunnel
!— before the SPT switchover.

After that, my streamex box is at 192.168.1.22, and my multicast traffic is 239.255.255.2. Finally I use smcroute to make static route.

#smcroute -d

#smcroute -a eth0 192.168.1.22 239.255.255.2 cbn

Next question, how to make my linux box using dynamic multicast routing protocol, like pim.

1. Use xorp .

2. Use pimd

how about the configuration ?.

Thanks to Johan

Tinggalkan Balasan

Isikan data di bawah atau klik salah satu ikon untuk log in:

Logo WordPress.com

You are commenting using your WordPress.com account. Logout / Ubah )

Gambar Twitter

You are commenting using your Twitter account. Logout / Ubah )

Foto Facebook

You are commenting using your Facebook account. Logout / Ubah )

Foto Google+

You are commenting using your Google+ account. Logout / Ubah )

Connecting to %s

%d blogger menyukai ini: